Плагин Advanced Category Excluder не работает с php 5.3

Плагин Advanced Category Excluder не работает с php 5.3Здравствуйте, сегодня на моем блоге случилось ЧП, а все из-за плагина Advanced Category Excluder Плагин Advanced Category Excluder не работает с php 5.3

Дело в том, что все ранее созданные копии постов, так автосохраненния, черновики, разные версии постов и т.д. Повылазили и в итоге каждого поста увеличилось копий и сайт стал страшно глючить и не работать. Первая мысль «меня взломали», вторая мысль «блин ну кому это все нужно было, трогать мой маленький пушистый блог». 

В итоге я стал лихорадочно доставать бэкапы базы данных сайта, но как я не пытался проблема не исчезала, я даже файлы и бэкапов вытащил и ничего не получалось. Далее я решил, что в коде wp закрался вредоносный код, который все портит и закрался он давно, так как бэкапы не помогали, а только сегодня активировался.

Подумал, что снесу все файлы и установлю старую базу данных, но вновь установленный пустой движок wp. Начал выклюать все плагины и «о чудо» сайт корректно заработал.

Начал включать плагины поочередно и нашел наглого бойца Advanced Category Excluder.

Мысль о том, что взломали именно этот плагин оставалась у меня до того момента, пока я не вспомнил, что на моем хостинге изменили версию php с 5.2 на 5.3

В этом собственно и была проблема  Плагин Advanced Category Excluder не работает с php 5.3

Следующая возникшая проблема, это поиск замены этому плагину, ведь мне нужно скрывать определнные категории с главной страницы и с rss. В итоге альтернатив не было найдено в виде плагинов, но был найден интересный код, который полностью заменил плагин Advanced Category Excluder.

Об этом посте в следующих постах моего блога, так что подписываемся и читаем Плагин Advanced Category Excluder не работает с php 5.3

 

Есть 1 комментарий.

Оставить комментарий

  Правила комментирования на блоге